✓ Solved

Can I get some help with SSL errors from certain browsers?

OK I'll do my best to explain. Certain people have told me that mysite is inaccessible due to an SSL error, but I cant confirm this because from my end (from home network and from cell phone 4G network) I cant duplicate the error. I have no idea why but for some reason it works completely fine for me in firefox, chrome, brave from all my devices. I'm sorry but I cant print out the error because no one has helped me by sending a screen shot of what the error says.

Can someone figure out why there is an ssl error? I'm using Letsencrypt for the SSL certificate.

Here is my sites-enabled .conf:

VirtualHost *:80

    ServerAdmin contact@pastlife.works
    ServerName pastlife.works
    ServerAlias www.pastlife.works

    DocumentRoot /var/www/pastlife.works    
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

RewriteEngine on
RewriteCond %{SERVER_NAME} =pastlife.works [OR]
RewriteCond %{SERVER_NAME} =www.pastlife.works
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]


vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Here is my sites-enabled -le-ssl.conf:

IfModule mod_ssl.c
VirtualHost *:443

    ServerAdmin contact@pastlife.works
    ServerName pastlife.works
    ServerAlias www.pastlife.works
    DocumentRoot /var/www/pastlife.works

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLCertificateFile /etc/letsencrypt/live/pastlife.works/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/pastlife.works/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf


Here is my .htacces file:

Options +FollowSymLinks

RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^$
RewriteCond %{HTTP_HOST} ^pastlife.works [nc]
RewriteRule ^(.*)$ https://pastlife.works/$1 [L,R=301,nc]
Options -Indexes
ServerSignature off

** The only other thing I changed was adding this to apache2.conf:**

Directory /var/www/pastlife.works

AllowOverride All

Options -Indexes

    ServerSignature off


Thank you so much for your time and efforts.

6 Replies

✓ Best Answer

Thanks for the help @LouWestin The people at Letsencrypt helped me solve it. It was a ipv4-exclusive .config file that I edited incorrectly. You can see in the link above.

sorry about formatting

IPv6 is configured, but not IPv4. That’s going to be an issue for those who don’t have IPv6 setup by their ISP and fallback or run on IPv4.

You need to setup your IPv4 address.


Thank you so much for your reply!
Is that something I do from Linode dashboard under domains, or do I need to change an apache config file?

You’ll want to check your DNS settings to make sure you even setup your domain name with an IPv4 address.

And go through part of this guide, starting with set host name to make sure you setup the IPv4 address yes double check Apache https://www.linode.com/docs/guides/getting-started/

I used the autogenerate domain settings when I setup the linode based on the operating system I chose. The other websites I'm hosting on the same server work perfectly fine with the same IPv4 settings. Which I set up the same exact way. All the .conf and .htacces files for lexrex & starseed-growers were copied from pastlife.works

I'm trying to get help at letsencrypt community as well

There might be some useful information here:


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct