✓ Solved

How do I use the aws cli for linode s3?

When I run aws s3 ls --endpoint=https://[my account].ap-south-1.linodeobjects.com I see only 'Buckets' in the result but I do have a bucket there.

This guide https://www.linode.com/docs/products/storage/object-storage/guides/aws-cli/ tells me to just press enter to keep the default US region but there is none. I get the same result for the cli query even if I leave it unfilled.

1 Reply

✓ Best Answer

I set up the AWS CLI on my Mac and can confirm that hitting Enter and leaving the default region as None should work. The syntax for listing buckets using the AWS CLI is a bit different from what you've listed - you shouldn't need to specify your account as part of the endpoint. Here's the command that worked for me to list my buckets in Singapore:

aws s3 ls --endpoint=https://ap-south-1.linodeobjects.com

As long as you set up your access key and secret key when configuring the AWS CLI, you should just be able to specify the endpoint without including your account details.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct