✓ Solved

Mount fails for ecryptfs container file

Hello everyone. I'm a new user experimenting with a basic Alpine Nanode (1GB RAM/25 GB storage )

I'm trying to create a secure storage container on the Node. I have no experience with VMs or cloud machines but lots with metal. This is what I have done:

  1. Created a 1G container file with fallocate.
  2. Created a key with dd.
  3. Formatted the container/assigned key with cryptsetup/LUKS.
  4. opened the device / confirmed it opens in /dev/mapper.
  5. created a filesystem on the open block device

All of thes operations worked exactly as I would have expected. However, when I try to mount the block device, mount fails:
a:~/keys/fc0# file -s /dev/mapper/fc0 /dev/mapper/fc0: SGI XFS filesystem data (blksz 4096, inosz 512, v2 dirs)

a:~/keys/fc0# mount /dev/mapper/fc0 /srv/fc0/ mount: mounting /dev/mapper/fc0 on /srv/fc0/ failed: Invalid argument

I have No Idea what's going on. Any help would be very appreciated. Thanks.

1 Reply

✓ Best Answer

Turns out the issue is Alpine not Linode.
Alpine has issues with mounting btrfs and xfs on diskless systems.

Switching the fs to ext resolves the issue.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct