How do I make the object storage public read and write?

I have tried with no avail to make the object storage public read and write. I did it from the linode cloud manager, and even used the api. It still doesn't work. It shows that the bucket is public read or write, but I can't access the items in it. All the items are private. Can anyone help me?

1 Reply

Hey there -

It sounds like a permissions issue with the objects within your bucket. While updating a bucket to Read/Write, the objects may still be Private.

This guide has more information on updating Access Control List (ACLs) in Cloud Manager at both the bucket and object level:

Here's our API documentation for updating ACLs:

I hope this information helps!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct