✓ Solved

Complete beginner question

I just try to save in nano in Ubuntu terminal but instead it opens windows explorer asking me to open a file.

By the way CTRL X doesnt work at all. I think Windows takes over the commands of the terminal. I read this article:


How can I do to just save my file in nano terminal? thx

3 Replies

✓ Best Answer

Well, thx for the answers.

I cant try vim cause I just follow a tutorial on a youtube channel and I follow the steps.
This is what I follow:


My terminal is a specific HTTPS address https://cloud.linode.com/linodes/…

In the tutorial, there is no such thing. I will try your solutions. I work with Linode.

Hey there!

That's definitely weird. Even in Windows, ctrl+x is keyboard shortcut for "Cut". I suggest looking into your hot key assignments on your keyboard.

Someone reported an issue with nano, SSH, and Windows with CentOS back in 2016 in this Stack Exchange post. The solution there may be useful to you.

You could also try a different terminal emulator. If you're using PuTTY, there are several alternatives that might be worth giving a shot.

Finally, if nano isn't saving files, have you tried vim? It's a text editor with a bit steeper of a learning curve but not too difficult to get a handle on. This video on the Linode YouTube channel gives a pretty good overview of how get started with vim.

I think my commands are doubled by the terminal and windows. Kinda weird.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct