vncviewer is not getting connected

I am creating tunnel using this method: ssh root@ -L 61000:localhost:5901 .but vncviewer says connection refused by computer. I suddenly get connected but most of the time it does not work for me.

before creating tunnel I am checking the display number and applying. Can anyone please help me?

1 Reply

Linode Staff

Is there any particular reason you want to use port 61000 for your local port? The VNC Setup Guide suggests using 5901 and that's the one I've had success with in the past.

This article titled SSH Local and Remote Port Forwarding with VNC gives a few different examples using port 6999, however, I wasn't able to get that to work either.

And finally, according to this article titled VNC Port Forwarding: Everything Important You Need To Know, you may need to configure your router settings.

I hope this helps!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct