Why a server cannot ping other's private IP

I have two linode server A and B with private IPs. Server A can ping Server B private IP but Server B ping cannot ping Server A private IP.

I know all private IPs can actually ping each other so what could be the problem and how can it be solved.

Both server are Ubuntu.

Please help.

5 Replies

so what could be the problem and how can it be solved.

Your firewall is not configured correctly on the node not replying to ping.

-- sw

Thanks for the reply. Sorry I omitted one thing, there is a dev server with a private IP which can ping Server A and vice verse.

simple Illustration
Server A -- Can ping B and C
Server B -- Cannot Ping A and C
Server C -- Can ping A and B


Server B -- Cannot Ping A and C

This is the one with the misconfigured firewall. It's blocking ICMP Echo requests.

-- sw

ufw is not active. This is a fresh server that has been deployed

You can have an active firewall without ufw…and you can have firewall rules that ufw doesn’t/can’t manage.

This is because ufw is not the firewall. It’s only a friendly front-end™ to the real firewall to make it easy for you to use. It’s pretty easy to go behind ufws back. Sometimes that’s the only way…

Also, you need to make sure the private IP is even configured on Server B… See:


Try putting A's & C's private IP addresses in B's /etc/hosts file:

192.168.xxx.xxy                   server-a
192.168.xxx.xxz                   server-c

Since addresses the private IP address range are not in any kind of DNS system and their traffic is not routable to other networks, this is the only way you can make them known to other systems in the same data center.

— sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct