SSH not working, Lish-initramfs

I Tried installing Kali via Marketplace and as the username I put a uppercase letter, which lead to a RegEx error in the Script when adding the User and then setting up vnc with that User(Log). I also couldnt connect or ping in the first time while I could give comments via lish [initramfs][first boot it didn finish Installation. ] after just rebooting the Server and waitng some time, I was able to ssh in as root and add a new User and Start vnc, which worked fine.
I then installed kali Desktop env "Apt install Kali-Desktop-Xfce", "update-alternatives --config X-Session-Manager" -> chose the Right env[2], then "init6" for reboot.
Now I can again only connect via lish [initramfs] and ping, ssh dont work. Any help?
[PS: After the first reboot it chaged from initramfs to a login-withTheIP and then i was able to start vnc as explained above]

Does it makes sense to just reinstall everything ? If so does that Change my plan?
Rly hope anyone can help ;) ty <3

1 Reply

Since your instance is brand new and you've pinpointed a configuration error right off the bat, I would suggest deleting it and starting over with a fresh deployment. This time, make sure your username is only using lowercase letters, numbers, dashes, or underscores.

There's no extra monetary cost to tearing down a Linode and spinning another one up so create and delete as many as you need. It'll only cost you some additional time.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct