s3fs: bucket name contains an illegal character

Summary: Works with s3fs in the shell, but not with /etc/fstab.

I've been follwing this answer:

mount -a
s3fs: BUCKET /mount/skyffbusskrs -- bucket name contains an illegal character.

my /etc/fstab entry:

skyffbusskrs /mount/skyffbusskrs fuse.s3fs _netdev,allow_other,use_path_request_style,passwd_file=/etc/passwd-s3fs,url=https://eu-central-1.linodeobjects.com/ 0 0

But this command in the shell works! (same parameters as far as I can see):

s3fs skyffbusskrs /mount/skyffbusskrs -o passwd_file=/etc/passwd-s3fs -o url=https://eu-central-1.linodeobjects.com/ -o use_path_request_style -o dbglevel=info -f -o curldbg

Debian 11

Any thoughts?

2 Replies

Hey there,

That is definitely a bit strange. I was able to follow the same linked post without a single hiccup. This included modifying my /etc/fstab to reflect the additional mount, even rebooting to make sure it mounted again automatically.

The illegal character error you received would indicate that there was a problem with the bucket name, though based on your shared input there doesn't seem to be one.

It's possible there is something I am not seeing so you may want to comb over that line to be sure there is nothing accidentally included that shouldn't be there, but otherwise your sample /etc/fstab looks correct.

The only other prominent difference I am seeing between your attempted input and the outlined steps is the addition of passwd_file=/etc/passwd-s3fs. Have you tried removing that?

If you want a reference of the invalid characters associated with S3 across a few tools you can check out another Community Post here. Shout out to my colleague @bshoemaker, who put in some time to break down all of those pitfalls in the linked post.

So I'm seeing this too. It appears to be a "sometimes" problem. I just saw the "illegal character" error trying to mount a couple of buckets. Tried it several times in a row, on two different buckets, and kept getting the error (even though I had just previously had them mounted and then unmounted, mind you). I "sudo su" in preparation to make some edits, but just want to try mounting one more time. Exit outta su, tried mounting, and boom both buckets mount fine.

My fstab:

<bucket 1> /mnt/<mountpoint1> fuse.s3fs _netdev,allow_other,umask=0022,url=https://us-southeast-1.linodeobjects.com,passwd_file=<path>,use_sse=custom:<path>,nomultipart 0 0

<bucket 2> /mnt/<mountpoint2> fuse.s3fs _netdev,allow_other,umask=0022,url=https://us-southeast-1.linodeobjects.com,passwd_file=<path>,use_sse=custom:<path>,nomultipart 0 0

Bucket names are just regular letters and a hyphen.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct