Fedora 37 and IPv6 not Assigned by SLAAC

I upgraded to Fedora 37 (on 12/18/2022) and noticed that HTTPD failed. It turned out that my IPv6 address was not the one assigned to the server.

After several reboots and many messages back and forth with tech support, it turned out that I needed to look at nmcli and my connection configuration.

Editing files did not do anything (/etc/sysctl.conf or /etc/sysconfig/network-scripts/). Turning off the Linode auto-config network options did not work either. I had to use nmcli.

The following command will give you the CONNECTION NAME

nmcli device status

Next, issue the command to see your ipv4 and ipv6 settings.

nmcli -p con show $YOUR_CONNECTION_NAME

I saw that ipv6.ip6-privacy and ipv6.addr-gen-mode had a negative values (status unknown). It did not matter what was hardcoded in /etc/sysconfig/network-scripts/*.

The following command and a reboot fixed it.

nmcli connection modify $YOUR_CONNECTION_NAME ipv6.ip6-privacy 0 ipv6.addr-gen-mode eui64

I can now hardcode the IPv6 address and/or use the auto-config network options from Linode.

This problem is solved. I am posting this solution in case anyone else has the same issue.

2 Replies

Hello @up2long,

We really appreciate you taking the time to share this fix! It looks like you put a lot of work into this, and the fact you are sharing it means a lot.

Huge thanks @up2long for taking the time to post this. Had the same issues on a custom image (RHEL9) and the "ipv6.addr-gen-mode eui64" was the thing solving it for me, I could leave the ipv6.ip6-privacy at the default (-1) it seems.

I tip my hat.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct