Web browser accessible desktop without host software need

Hoping your expertise can offer some input as to how best to accomplish a desired outcome. Many years ago, was able to access a remote desktop via any web browser using Windows Server and Citrix Nfuse. This enabled full functionality without any needed plug-ins or software other than authenticating to the server's webpage.

Surely this must be possible with modern Linux-based resources, but have not been able to uncover any working solutions at all. So I am seeking a solution which will enable access to a sort of XFCE desktop environment via authenticating to Linode host's IP address, from any host's browser, which does not necessitate downloading and installing some supporting local software.

2 Replies

To achieve this, you can use a web-based VNC (Virtual Network Computing) client that allows you to access an XFCE desktop environment on your Linode server directly through a web browser. One such web-based VNC client is noVNC. If you want to run the VNC server and noVNC at startup, you can create systemd services for both components. This will enable you to access the XFCE desktop environment without manually starting the services each time your Linode server reboots.

Step by step installation

sudo apt install xfce4 xfce4-goodies tigervnc-standalone-server
nano ~/.vnc/xstartup


xrdb $HOME/.Xresources
startxfce4 &

chmod +x ~/.vnc/xstartup
sudo apt install git python3-numpy python3-websockify
git clone https://github.com/novnc/noVNC.git

vncserver :1 -geometry 1280x720 -depth 24
./noVNC/utils/launch.sh --vnc localhost:5901

sudo ufw allow 6080

Now you should be able to access the XFCE desktop environment on your Linode server by navigating to http://your-linode-ip:6080 in any web browser.

I followed your path, but :
xrdb $HOME/.Xresources -> fails.. file not found

and one line is wrong.. did you mean "#!/bin/sh"

and the following file is also not there anymore:

Here an update from me:

Explanation (looks like the same like here).. the .Xresources just create an empty file.

For the noVNC -> Just start: noVNC/utils/novnc_proxy --vnclocalhost:5901

Problem im still try to resolve: SUDO on vncserver works..without sudo -> it kills himself, without telling why.

Found it: the & after startxfce4 you need to remove.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct