✓ Solved

How to prevent my /etc/resolv.conf from repeatedly getting overwritten?

I'm running a Debian 11 Linode with neither the "resolvconf" nor the "openresolv" utilities being installed.

Periodically, my /etc/resolv.conf keeps getting overwritten with the following …

domain ip.linodeusercontent.com
search ip.linodeusercontent.com

I repeatedly replace that data with my own values, but later, it always gets overwritten again with the same values listed above.

How can I prevent these linode nameserver references from overwriting my own?

Thank you very much in advance.

3 Replies

✓ Best Answer

I suggest making sure Network Helper is disabled and rebooting your instance. Network Helper maintains the /etc/resolv.conf file on Debian based systems so this sounds like it could be the cause of your issue. By rebooting your system, you'll ensure the setting has been saved.

If you've done this already and the file is still being overwritten, you should out to the Support Team in a ticket to let them know, since that's not expected behavior.

UPDATE: It seems like my linode is periodically getting DHCP updates, and now I think that this is what's causing my /etc/resolv.conf to keep getting overwritten.

How can I disable those periodic DHCP updates?

FURTHER UPDATE: And it seems as if these DHCP updates are being managed through the linode's "cloud" capabilities. I don't want my own configurations to be overwritten by anything from anywhere in any cloud, so perhaps I need to get those "cloud" features turned off somehow … ???

Thank you very much!

Network Helper is turned off, but I haven't rebooted in a long time, so I'm rebooting now. If that doesn't fix the problem, I'll indeed file a ticket, as you have suggested.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct