Unable to get wp admin dashboard password

Created a wp server via marketplace on Linode. But I could not able to get a password for my wp-admin dashboard. If I enter the following command cat /root/.linode_credentials.txt to get an automated generated password on the Lish console but it shows that no such file or directory. Even though I used the password reset option using mail, I didn't receive any mail for password resetting. Please provide me a solution to get a wp-admin dashboard password.

14 Replies

You most likely may need to wait a little longer for your Linode to be fully deployed. WordPress can take about 5 minutes or more to finish provisioning.

I ran through our guide on Deploying WordPress through the Linode Marketplace. Throughout this process, I watched the WordPress installation through the Lish Console to make sure that the installation had completed.

Once I saw Installation Complete in Lish, I tried:

cat /root/.linode_credentials.txt

From there I was able to obtain the necessary crendentials.

I recommend spinning up a new WordPress app from the Marketplace and track it's progress through the Lish Console. When you notice the installation is done in Lish, you will be able to access the credentials and then continue on with the rest of the guide.

I am having the same problem, been waiting since 30 minutes now. Should I wait for more?

@cicwill sir, I tried the command one time I got the automatically generated credentials by doing a root login. But now I have created a new instance on Linode and now I could not able to get the credentials by using cat /root/.linode_credentials.txt this command. Please give me a solution sir.

@akash Our Administrators are currently investigating an issue with our Marketplace Applications. You can stay up to date on their progress by checking the status page.

In the meantime, if you need to deploy a WordPress site ASAP, you can follow the instructions in this guide.

@tlambert The issue is still existing. When they resolve the issue, sir?

The issue that was causing problems with our Marketplace applications was resolved back on July 20th. I just spun up a test WordPress server through the Marketplace to check if I received the credentials with cat /root/.linode_credentials.txt after it was finished installing and they came up without a problem:

$ cat /root/.linode_credentials.txt
mysql_root_password:<long-secret password>
wp_db_pass:<long-secret password>
wp_admin_pass:<long-secret password>

I suggest trying to create another WordPress server and waiting 5-10 minutes to ensure it has installed correctly. If that still doesn't work, you may want to contact the Support Team through a Support Ticket to let them know what you're experiencing.

Why use the marketplace's buggy system? WP is easy to install once you have a LAMP stack, which is also easy to install. There are a zillion websites on how to do it, including one done by the Linode staff.

The problem persists until September 30, 2023, I have installed WordPress and Woocomerce 10 times from the linode´s marketplace and it never gives me the credentials with the following command indicated in the documentation

cat /root/.linode_credentials.txt

It's a waste of time

@coffe_server - that sounds like a really frustrating experience. I just ran some tests of our WordPress Marketplace with both a LAMP and LEMP stack and ran into an error in one out of roughly 10 deploys. I doubt that you and I used that same input variables so that may have something to do with it. Either way, I brought it up with the Marketplace team and they are looking into it further.

There are some troubleshooting steps you can take to see what may have gone wrong during the deployment process of your Marketplace app. Specifically, checking the /var/log/stackscript.log file will allow you to see the installation log of the app. If you can share that information with us, either here or with the Linode Support Team that would help us with the investigation.

Hello, same problem here.

I created multiple instances of wordpress with marketplace but always :

cat: /root/.linode_credentials.txt: No such file or directory

Could we have a solution ?

Solution find here : https://wordpress.org/documentation/article/reset-your-password/#:~:text=to%20your%20website.-,To%20Change%20Your%20Password,Click%20the%20Update%20User%20button.,-Your%20new%20password

  1. Create your new md5 password :

  2. SSH connexion to your linode server

  3. Run the sql command
    "mysql -u root -p" (log in to MySQL)

  4. Enter the root password of your server

  5. "use (name-of-database)" (select WordPress database)

  6. "show tables;" (you’re looking for a table name with “users” at the end)

  7. “SELECT ID, user_login, user_pass FROM (name-of-table-you-found);”

  8. 2 options to update your database :

“UPDATE (name-of-table-you-found) SET user_pass=”(MD5-string-you-made)” WHERE ID = (id#-of-account-you-are-reseting-password-for);” (actually changes the password)


Update (name-of-table-you-found) set user_pass="(MD5-string-you-made)" where user_login="(your admin user)"

  1. “SELECT ID, user_login, user_pass FROM (name-of-table-you-found);” (confirm that it was changed)

  2. (type Control-D to exit mysql client)

I've got the same issue here. I know I saw it on my Linode at one point. Does it get deleted on reboot? Now I can't log into Wordpress

I'm running into the exact same issue with my WordPress login after installing it on my Linode via the Marketplace. Despite entering the correct password (double and triple-checked!), I keep getting that frustrating incorrect password error.

I've been at this for over an hour, thinking maybe it's just a temporary glitch, but no luck so far. This is definitely a bummer that we're all stuck.

Hey @salomewaringamungai - I just deployed a WordPress App from the Marketplace on a LAMP stack and didn't run into any issues. Did you check /var/log/stackscript.log to ensure the application deployed correctly? If it did, you'll see something similar to the following:

PLAY RECAP *********************************************************************
localhost                  : ok=64   changed=44   unreachable=0    failed=0    skipped=12   rescued=0    ignored=0   

Installation Complete

Were you also getting an error when you entered the command to retrieve the credentials? If so, what was the error?

cat /root/.credentials.txt

I noticed when I just tested this that I was getting a bit of an error with the layout in WebLish where my login and hostname were printing at the end of the Wordpress admin password:

Wordpress Admin User: admin
Wordpress Admin Password: <long-and-secure-wordpress-admin-password>root@localhost:~#

In this case, you'll just need to be careful you aren't also adding the root@localhost:~# portion to your Wordpress Admin Password.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct