SSL error, invalid certificate when Linode bucket has . 'dot'

Due to the SSL certificate is pointing to only the endpoint and it is not a wildcard certificate, SSL is invalid.

Without using dot, DNS resolution for cloudflare CDN fails.

Creating a bucket with dot "" has certificate SSL invalid.

do you guys have any suggestion or Linode team might need to solve it?

1 Reply

Yes, the certificates for our Object Storage endpoints are only good for one domain level. The dots in your bucket name is leading to each part being read as a subdomain. So your options would be to use a different bucket name without dots or to set up a custom domain with your own SSL Certificate.

To help you do that, I'll link you to our official guide and a great Community Site post about it:

Configure a Custom Domain (with a TLS/SSL Certificate)

How to use custom domain for object storage

Hopefully one of those solutions works for you.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct