I am having trouble getting a Graphic UI installed

Linode Staff

I ran the sudo apt-get install xfce4 command

Tried to run: exec /sbin/getty -8 38400 tty1 &

Then ran: startxfce4

I then tried GlishLaunch Graphical Web Console but its just saying:

invalid session

Any ideas?

9 Replies

Looks like you may have run the 'sudo apt-get install xfce4' & 'startxfce4' commands outside of the Glish console.

Steps to correct this issue:

1) Manually start getty with this command in the Linode’s command line:

exec /sbin/getty -8 38400 tty1 &

2) Once this is done, use the Glish link in your “Remote Access” tab via your Linode Manager to launch the Graphical Web Console

3) A new window will pop up. In that window, log into your Glish console with your user name and password

4) Once logged into your Glish console, run the command below, (within the Glish Console itself), to install the Desktop Environment:

sudo apt-get install xfce4

5)Once xfce4 is installed, we’ll need to start the service using the following command:

startxfce4

You’ll now see the graphic user interface. You can now use the icons on the desktop to navigate around, but bringing the mouse cursor to the top and bottom of that screen should show you even more options.

You now have your desktop running on your Linode.

Hi and thanks for your reply.

Ok so from the beginning to make sure i have not missed anything

1) Deploy an Image from Dashboard
2) ubuntu 18.04 LTS
3) Boot image
4) Click remote access tab
5) Do you connect initially with Lish via Browser - Launch Lish Console or one of the other remote access methods?

Thanks for your help.
Justin

6) i connected via Lish via Browser Launch Lish Console
logged in as root with my password
7) ran the exec /sbin/getty -8 38400 tty1 &
it returned this:

[email protected]:~# exec /sbin/getty -8 38400 tty1 &
[1] 1143
[email protected]:~#

8) i then tried click Glish link in my “Remote Access” tab via my Linode Manager to launch the Graphical Web Console however it just says "Invalid Session. Please try again from remote access tab"

Any ideas?

Hey there,

It looks like the issue that you're seeing is because you're accessing Lish through your browser, when instead you need to click on the Launch Graphical Web Console link and enter the commands there. Once you've accessed this console, you just need to login normally and enter the following commands:

sudo apt-get install xfce4
startxfce4

I just got this set up on ubuntu 18 to make sure your distro is compatible, so I think follow those steps should work for you.

Hope that helps!

Hi and thanks for your reply.

See my screen recording to show im sure im doing exactly this but getting an error no matter what i try?

https://www.dropbox.com/s/lndkop30yzb2f41/Untitled.mp4?dl=0

Thanks again.

No problem at all, I'm happy to help. Have you been able to try accessing Glish through a different web browser? Some browsers can have compatibility issues with Glish, so I think trying a different one may work for you. That error specifically usually occurs for this reason.

mate you are SPOT ON! It was Chrome not allowing the connection. I downloaded Firefox and it worked first time.

Thanks for all your help guys. Much appreciated.

Have a great day

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct