cPanel w/Multiple IP's

Any Linode users running cPanel with multiple IP's?

Had 3 working fine, added a 4th, lost ping from the outside world to all but the 4th.

Manually configured the devices (cPanel uses DHCP & assigns the others on the fly via a script), no good.

Removed the newly-added IP from linode, rebooted, and the original 3 came back up. Went back to dhcp, rebooted & they're still up.

Anyone else have a similar experience?

2 Replies

No, never had any trouble. Have you tried rebuilding the IP Address Pool from within WHM?

Thanks for the reply. Yeah, tried that, but it didn't help. The situation is resolved now.

It seems to be a "he said she said" between cPanel & my host, the latter of which strongly discourages DHCP for boxes requiring multiple IP's.

In the past eth0 had been dhcp, but I ended up hard assigning ifcfg-eth0 to my 1st IP (which happens to be the one associated with my cPanel license) and letting WHM do its thing via ipaliases for the others.

During the course of things I discovered after adding the 4th IP (all four of which are on different subnets) that the most recent was being assigned as the primary. The host assured me it wasn't a routing issue on their end.

Why it worked fine with 3, then spazzed out after adding the 4th shall remain a mystery.

I am just very glad my host has a console access method to get me into the box when the IP's went haywire.

Take care!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct