Messed up DNS on simplest possibe linode.

I need a little push getting DNS to work.

Here is my /etc/hosts:

127.0.0.1               localhost.localdomain         localhost
74.207.mmm.nnn  host.mydomain.net             host

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

where mmm.nnn = my last two quads of my linode's ip

host=my linode;

mydomain registered at go data.

The domain was registered a week ago, and GoDaddy apparently automatically parked records for

mydomain.net

mail.mydomain.net

www.mydomain.net

So about 24 hours ago, I logged into GoDaddy and initaited pointing the nameservers for mydomain.net to ns?.linode.com for ? = 1,2,3,4. Then I logged into linode.com and used the DNS Manager to create this record:

; mydomain.net [83760]
$TTL 86400
@    IN  SOA ns1.linode.com. my_email.gmail.com. (
                    2010032859
                    14400
                    14400
                    1209600
                    86400 
                )
@        NS  ns1.linode.com.
@        NS  ns2.linode.com.
@        NS  ns3.linode.com.
@        NS  ns4.linode.com.
@        NS  ns5.linode.com.
@            MX  10  mail.mydomain.net.
@            MX  1   host.mydomain.net.
@            A   74.207.mmm.nnn
www            A   74.207.mmm.nnn
mail        A   74.207.mmm.nnn
host        A   74.207.mmm.nnn

The mail.mydomain.net and www.mydomain.net records got updated pretty quickly (less than an hour) and a few hours later the bare subdomain 'mydomain.net' was also being served by Linode's DNS. I verified this with dig and ping.

But! A day later, host.mydomain.net remains invisible. Here is what dig says:

[email protected]:~# dig host

; <<>> DiG 9.6.1-P1 <<>> host
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 51563
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;host.            IN  A

;; AUTHORITY SECTION:
.            86400   IN  SOA a.root-servers.net. nstld.verisign-grs.com. 2010032800 1800 900 604800 86400

;; Query time: 105 msec
;; SERVER: 74.207.241.5#53(74.207.241.5)
;; WHEN: Sun Mar 28 11:49:59 2010
;; MSG SIZE  rcvd: 100

Again, I have redacted my true hostname as 'host'.

Incidentally, I have two MX records becasue (1) I already had one from GoDaddy and (2) I created another one after following the (As an aside, I currently do not have reverse ARP for this host because… Linode.com obviously does not see the A record for host any better than dig does…which is to say not at all yet.)

I'm guessing I have waited long enough for the DNS changes to propagate.

The only thing that makes 'host' sprecial (compared to 'mail' or 'www') is that 'host' is the actual hostname of the linode. Is putting an actual hostname in an A record a misconfiguration?

I've been reading about DNS, but I am stuck.

Any clues will be appreciated.

Thanks!

5 Replies

Have you set Linode DNS servers in your registrar's domain configuration?

Try to ask Linode servers (and possibly yours) with argument of dig: @dns.server.tld

I did manage to figure out which domain you're asking about, and the records in the DNS Manager are being served correctly by our servers. Since you've decided to hide information, though, I have to make a few guesses as to why you're having trouble. It looks like you're trying to lookup the bare hostname without the domain (dig host instead of dig host.example.com) and the NXDOMAIN response from the root server backs that up. Looking up your bare hostname like that won't work unless your domain name is in your list of search domains (in /etc/resolv.conf). If you do the lookup with the full hostname it should work.

Also, a couple of quick notes about dig: 1) /etc/hosts has nothing to do with DNS and dig ignores it. 2) Adding the '+trace' flag to your dig queries usually helps to determine where the problem is.

-James

@drake: Thanks for reading and taking the time to reply. I think so… the first thing I did was log into my registrar's website and use their interface to set the DNS dor mydomain.net to the Linode.com DNS. I know that worked, because I am now serving webpages from my linode and (with some problems) sending and receiving mail with postfix/dovecot on my linode.

I am just (re)learning how to use dig and issued this command from my laptop 'rubuntu' at home:

[email protected]:~$ dig @ns1.linode.com host.mydomain.net

; <<>> DiG 9.6.1-P2 <<>> @ns1.linode.com host.mydomain.net
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20567
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 5
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;host.mydomain.net.        IN  A

;; ANSWER SECTION:
host.mydomain.net.    86400   IN  A   74.207.mmm.nnn

;; AUTHORITY SECTION:
mydomain.net.        86400   IN  NS  ns4.linode.com.
mydomain.net.        86400   IN  NS  ns2.linode.com.
mydomain.net.        86400   IN  NS  ns3.linode.com.
mydomain.net.        86400   IN  NS  ns1.linode.com.
mydomain.net.        86400   IN  NS  ns5.linode.com.

;; ADDITIONAL SECTION:
ns1.linode.com.        86400   IN  A   69.93.127.10
ns2.linode.com.        86400   IN  A   65.19.178.10
ns3.linode.com.        86400   IN  A   75.127.96.10
ns4.linode.com.        86400   IN  A   207.192.70.10
ns5.linode.com.        86400   IN  A   109.74.194.10

;; Query time: 63 msec
;; SERVER: 69.93.127.10#53(69.93.127.10)
;; WHEN: Sun Mar 28 12:30:35 2010
;; MSG SIZE  rcvd: 236

where again I have replaced th actual machine name with 'host' and my registered domain with 'mydomain'. Dig got the correct IP number for my linode, too!

So why does just a plain old 'dig host.mydomain.net' return NXDOMAIN, especially when 'dig other.mydomain.net' finds and returns a domain record, for other=mail,www ?

Now even more puzzled, but maybe that's telling me something.

Thanks. The plot thickens!

@lrgeek: Thanks.

1. Thank you for confirming that dig is not "influenced" by /etc/hosts. It would be weird if it were.

2. I have tried dig with the fqdn of my host, not just the bare hostname. Sorry for the confusion. Here is actual output, again withy redactions:

[email protected]:~$ dig host.mydomain.net

; <<>> DiG 9.6.1-P2 <<>> host.mydomain.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 38767
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;host.mydomain.net.        IN  A

;; Query time: 1 msec
;; SERVER: 192.168.2.1#53(192.168.2.1)
;; WHEN: Sun Mar 28 12:44:37 2010
;; MSG SIZE  rcvd: 40

But if I 'dig @ns1.linode.com host.mydomain.net' I actually get a good record! (See another post in this thread.)

3. I appreciate you looking at my actual name records. I am redacting only to minimize casual drive-by shootings before my site is better secured while looking for some help on the open forum. If you think I should open a private ticket, I will do that.

Thanks!

I opened a ticket to provide more detailed information about my domain and had an answer very quickly. Great service!

For whatever reason, Google's DNS servers (which I use in my home office) have picked up all but one of my name records. The missing record is the host.mydomain.net record. So I pointed my office router to OpenDNS and everything works great.

In retrospect, all I had to do to figure this out and pick a DNS was

dig @ host.mydomain.net

Note that I am not endorsing or disparaging any free DNS over any other. I'm just sharing what I learned.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct