Apache Sym Links and Wordpress?

So I'm trying to use "pretty links" for my wordpress blog but all the links are broken when I turn them on (posts, pages, everything).

I think it has something to do with the .htaccess file and symbolic links.

Here is my .htaccess which I think is correct.. but it is simply not working.

Options +FollowSymLinks
# BEGIN WordPress
 <ifmodule mod_rewrite.c="">RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]</ifmodule> 

# END WordPress

3 Replies

Do you have mod rewrite installed? Use httpd -M command via SSH and look for rewirite_module

Turns out that I had installed it but never enabled it (Does ubuntu not enable it by default?)

In any case thanks for the suggestion obs it helped me track down the fix.

You're welcome, and I guess ubuntu doesn't, I prefer to compile my own.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct