IPv6 backend node support

Linode Staff

IPv6 backend node address validation is fixed. You can enter in either address:port or [address]:port.


2 Replies

I'm definitely able to enter the address now (either format), but haven't been able to actually use an IPv6 back-end successfully.

I may just be missing something simple, but I've double checked the address I'm using, verified there is no filtering going on (I didn't have any firewall blocked connections logged, but I've also completely opened things as a test), and can successfully access the same address/port from other public IPv6 machines (including a Dallas Linode). Yet the balancer shows it down and fails to connect a client. I also see none of the health checks I was getting when configured with IPv4.

One item that may be worth noting is that the Linode is technically under a different account of mine (due to billing differences) than the balancer, though still in Newark.

Switching to the private IPv4 address of the same node works fine.

– David

PS: Of course, just sticking with IPv4 on the back-ends works just as well (including for IPv6 client connections), so clearly not a show-stopper. I'm mostly just twisting knobs here in terms of the beta.

Ah - yup - found another issue. I've disabled IPv6 node support for the time being.



Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct