How to enable PHP GD Library

I have this error in my cms:

GD is not present - image manipulation disabled

so I can't work with images the way I worked on old server, before I moved site to Linode.

I followed this instruction and installed GD library, all went well but I still get this error.

I also read that I might need to enable it in php.ini how do I that?

I have Ubuntu 9.10 Latest 2.6 ( php5.


4 Replies

My Debian 6 config, hope it helps:

root:/etc/php5/conf.d# cat gd.ini
; configuration for php GD module

Thanks, but can you be more specific, what should I do with the code you posted?

I searched /etc/php5/apache2/php.ini and did not found or anything that has gd in it…

EDIT: actually, I found only this:


; Tell the jpeg decode to libjpeg warnings and try to create

; a gd image. The warning will then be displayed as notices

; disabled by default

;gd.jpegignorewarning = 0

Check if you have /etc/php5/conf.d/gd.ini file with

If not, you can create it or put "" in your php.ini.

PD: remember to restart apache

Thats it ! I had gd.ini file, but it was not in php.ini I just added that line and now all fine :)

Thanks a lot!!! You saved my day! :)


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct