Needing the www.

Hi guys, on all of my sites on linode if I visit the URL without the www. then it can't find the website. Firefox seems to be able to work it out but chrome doesn't.

I was trying to set up google mail with the account today and required though it can't find it - and neither can chrome.

Is there something I missed during my lampstack installation?

I run ubuntu lucid

any help would be great.


5 Replies


; <<>> DiG 9.3.6-P1-RedHat-9.3.6-16.P1.el5_7.1 <<>>

;; global options: printcmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39663

;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0


; IN A

;; AUTHORITY SECTION: 86380 IN SOA 2012021195 14400 14400 1209600 86400

;; Query time: 0 msec


;; WHEN: Sun Feb 12 00:41:32 2012

;; MSG SIZE rcvd: 113


Layman's terms; you did not add in a A Record for the "@" root of your domain name. You need a default ip, you only set one for "www" subdomain that points to;


You haven't set any text records for;

1. TXT verification

2. SPF (email anti-spoof)

3. DKIM encryption with gmail.

Thanks for the reply - I really appreciate it.

So what exactly do I have to put in an A Record? By root do you mean '' - if I enter that into the box it disappears.

And cheers for the gmail info, I'll add that the next time I'm there.

Haha Awesome - I had no idea that I had lol

I have gone through setting gmail up and it all seems to be working. I can send and receive email via gmail though when I try to use the gmail address to send mail via the forum I get errors:

Zend_Mail_Protocol_Exception: ' ' appears to be a DNS hostname but cannot match TLD against known list, ' ' does not appear to be a valid local network name - library/Zend/Mail/Protocol/Abstract.php:145
Generated By: crazyfruitbat, 17 minutes ago

> Stack Trace

0 ZendMailProtocolAbstract->__construct(' ', 465)

1 ZendMailProtocolSmtp->__construct(' ', 465, Array)

2 ZendMailProtocolSmtpAuthLogin->__construct(' ', 465, Array)

3 ZendMailTransportSmtp->_sendMail()

4 ZendMailTransportAbstract->send(Object(Zend_Mail))

5 ZendMail->send()

6 XenForoMail->sendMail(Object(Zend_Mail))

7 XenForoMail->send('gareth@gma…', 'Gareth J.', Array, '', '', '')

8 XenForoMail->queue('gareth@gma…', 'Gareth J.')

9 XenForoModel_Conversation->insertConversationAlert(Array, Array, 'reply', Array, Array, Array)

10 XenForoModel_Conversation->addConversationReplyToRecipients(Array, Array, Array)

11 XenForoDataWriterConversationMaster->postSave()

12 XenForoDataWriter->save()

13 XenForoDataWriterConversationMessage->postSave()

14 XenForoDataWriter->save()

15 XenForoControllerPublic_Conversation->actionInsertReply()

16 XenForoFrontController->dispatch(Object(XenForo_RouteMatch))

17 XenForoFrontController->run()

18 {main}

Any idea?

Either the logging has a bug, or there's a space at the end of "" in your configuration.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct