Can't connect with PuTTY

Whenever I try to connect to my Linode using PuTTY the connection fails and I get this error message: "expected key exchange group packet from server". How can I fix this?

1 Reply

It seems like the might be 2 possible fixes for this:

  1. Update to the latest version of PuTTY.

  2. In PuTTY, go to Connections->SSH->KEX. Move "Diffie-Hellman group >exchange" to the bottom of the list and move "Diffie-Hellman group 14" >to the top of the list.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct