Server-status 403 error

I keep getting 403 error, and forbiden access for setting mod_status and looking it trough server-status.

Tried this … mod_status"> … od_status/">

all of this and in the end the location server-status is in /etc/apache2/mods-available/status.conf on my debian, but I tried with allow localhost, allow, with allow and all the iterrations give me the same result, Forbidden!

I tried it from my browser and from ssh root access with lynx and nothing. Where could the problem be?

Please help, as I spent hours on this and something is missing or blocking this, don't know how to determin what it is?

7 Replies

The only way I get it to work is to allow my ip address- a pain when it changes, but that is infrequent.Make sure to restart or reload apache after making changes.

I have to say I tried with IP address aswell, nothing, keep getting the same error :-( I am using Debian. I also restarted 100 times, reloaded, force-reloaded. I have 2 linodes, tried it on other one also, the same and that one has debian 5, all from linode installed. Really don't know where to look for anymore.

I found out this is working.

Alias /server-status /dev/null

SetHandler server-status

Order deny,allow

Deny from all

Allow from all

Without alias it doesn't work, without allow all, also not working, tried with ip/localhost/127. Something is wrong here, either tutorials are incomplete in explanation all over the web or linode tutorials are bad, as my server is set by reading them and now something is not write with this. Hope some expert could clerify what is what here, my apache doesn't recognize itself?!

Does your error log contain any details (e.g., source IP address) about the failed connection attempts?

I would suggest trying Allow from 127 ::1 your.ip.v4.addr your:ip:v6::addr. Don't use host names unless you have to, as Apache performs forward and reverse DNS queries to verify the address, taking extra time and effort.

127 - While most local networking uses, technically any address in the subnet could be used.

::1 - If you're using IPv6, this is the address used for local networking.

your.ip.v4.addr - The application trying to access Apache may be doing so using the public IP address, in which case the source will be the same IP address, not

your:ip:v6::addr - Same as above, for IPv6.

I did tr 127 but the same result. Can you help me I have bunch of log files in var/logs and don't know what or where to look for info on faild connection, can you point me to proper log file and I can test it and see?

grep -R ErrorLog /etc/apache2 will show you where errors are logged.

I have logs in /srv/www/my_site/logs/error.log for each of my sites

but also have many of them in var/log I think i got it and will search them. thanx


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct