Wordpress Custom Themes - Debian

Hi all,

An absolute beginner here with VPS/Debian. I've just managed to install Wordpress on my website (http://www.jazdosanjh.com) and when I attempt to install a custom theme it asks me for FTP details. I know I will need to make an VSFTP account thingy, but is it possible to not make one and somehow set certain permissions for me to be able to upload themes without that VSFTP thing?

If possible could you provide me some commands I can enter? I'm using Terminal on Mac OSx. To help my directory is /srv/www/jazdosanjh.com/public_html/

Thanks a lot for reading (and hopefully helping?)

3 Replies

Dont install FTP use SFTP (S stands for Secure)

You can download the themes files/plugins from wordpress.org and use filezilla to transfer files to the server /wp-content/themes , /wp-content/plugins

SFTP works via SSH so on the "Host" field of FileZilla enter "sftp://yourip" and your SSH logins for username and password. Plugin installations/wordpress updates also works this way. Just login via SFTP and upload the necessary files.

Thank you so much for your reply and help mate. I've managed to access the SFTP to install the custom theme. I love you. However, when I install the theme and then go to the WP dashboard to enable the theme, I'm prompted with "You do not have sufficient permissions to access this page.". The theme becomes enabled regardless once I return to the page. Any idea how I can fix that? Cheers

seems like a wordpress file permission problem. Read these



http://www.electronicworkplace.com/late … nd-folders">http://www.electronicworkplace.com/latest-updates/wordpress-correct-permissions-for-files-and-folders


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct