quota on ubuntu

whenever i try to enable quota

i get the error:

[email protected]:~# quotacheck -acguvm

quotacheck: Cannot stat() mounted device /dev/root: No such file or directory

quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

have tried to deploy centos and debian, i get the same error

tried ln -s /dev/xvda /dev/root

it just breaks on reboot

5 Replies

Putting your error into google returned numerous results, including:

http://www.daftspunk.com/code/fix-for-f … s-6-x.html">http://www.daftspunk.com/code/fix-for-file-system-quotas-devroot-symlink-breaks-linode-centos-6-x.html

Which suggests creating the symlink at startup, prior to any quota check.

Thank you sleddog for your help, i did check google results before opening this topic here

This file /etc/rc.sysinit does not exist in ubuntu

anyone has a solution ??

file /etc/rc.sysinit does not exit in ubuntu and debian

Why not just set the quota on the right device in the first place?

Adding these two lines to /etc/rc.local right before 'exit 0' worked for me (Ubuntu 14.04) :

# /etc/rc.local

ln -s /dev/xvda /dev/root
/etc/init.d/quota restart

exit 0

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct