Ubuntu - SFTP files permission denied

Hi guys, all was working fine for years but know i´m getting "permission denied" when deleting, uploading, setting permissions, etc. in FTP client. Only on "Home" i´m able to modify files.

I use PORT 103, specified in "/etc/ssh/sshd_config".

FTP port is set to 103.

I can navigate through files and directories, but can´t edit them, only on the "home" directory.

I don´t know if this is a clue, but the command "ssh -v localhost" shows:

OpenSSH_5.9p1 Debian-5ubuntu1.4, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to localhost [] port 22.
debug1: connect to address port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused

Any help?


3 Replies

The log says it's trying to connect to port 22 (the default for SSH). If you configured sshd to listen on port 103 instead, you need to also configure your FTP client to use port 103.

edit: sorry, I misread that and thought the log was for your FTP client. Could you run "ls -ls " on the server, with replaced with one of the files you're unsuccessfully trying to upload?

ls -ls doesn´t work: No such file or directory.

The problem is not just uploading, even setting permissions or deleting files… I´m able to modify files only on "home".


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct