Troubleshooting Slow Server Shutdown

Since a few days ago, my Linode Ubuntu (Latest 64 bit (4.9.7-x86_64-linode80)) seems to be having real issues with shutdown.

  • If I do a sudo shutdown -r now in an SSH session, the session disconnects, but never comes up again.

  • If I then visit the Linode control panel in a browser, my server is shown as still running with no shutdown having taken place [at least according to the job queue]

  • If I then issue a "Reboot" through the Linode control panel, the "System Shutdown" stage takes an age; usually over 2 minutes, but in one case nearly 4.

  • The subsequent "System Boot" only takes 7-8 seconds, as normal.

So, how do I go about troubleshooting what's holding up the shutdown procedure. Is there a "shutdown log" or somesuch I can consult?

3 Replies


I would try to reboot it over Lish console and see if it displays any output.



I would try to reboot it over Lish console and see if it displays any output.

Ah! Good thinking.

OK. I've tried issuing…

sudo shutdown -r now

…from an SSH session and then launched the Lish console. It showed that the shutdown process was hanging here:

~~![](<URL url=) … 4f3404.jpg">" />

I then rebooted from the web dashboard and opened Lish console. When I issued…

sudo shutdown -r now

…from within Lish, the shutdown process seemed to get one line further before hanging again –although chances are, it's hanging in the same place, but initiating the shutdown from within Lish is just giving an extra line of output, compared to initiating shutdown from SSH and monitoring it via Lish:

~~![](<URL url=) … 6dab72.jpg">" />

I'm wondering if it could be related to an updated Linux kernel?

A few days ago I ran apt-get update which [as it often does] listed a kernel update which is 'not going to be installed'. In these cases I usually run…

sudo apt-get update <whatever kernel="" upgrades="" are="" listed=""></whatever> manually trigger the update, as I get a bit OCD about keeping my updates available count at zero.

I've done this loads of times in the past, with no apparent ill-effects. But now I'm wondering has the kernel upgrade knackered something by over-writing the Linode-provided kernel? And, if so, how do I roll back to the Linode-issue kernel?~~~~


Edit grub to boot from the previous kernel and hardware reset the machine, won't hurt to give it a try.

If that doesn't work I would try rebooting into rescue mode and run a fsck check on the disk.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct