Minecraft Connection

I have used a Linode several times to host my son's Minecraft server. Never had an issue before. But for some reason I cannot get things to work. I have built the node from scratch a few times. No luck!

So here is what I have done.

1. Linode 2048 running Ubuntu 16.10

2. Followed this guide. https://www.linode.com/docs/application … and-ubuntu">https://www.linode.com/docs/applications/game-servers/minecraft-on-debian-and-ubuntu

3. Secured following this guide https://www.linode.com/docs/security/se … ur-server/">https://www.linode.com/docs/security/securing-your-server/ and I tried with no iptables running at all. Port 25565 is open.

4. Minecraft server fires up without any errors. Things look good.

5. Can't connect from client.

6. Tried on a few other Macs in the house, same deal.

Netstat shows we are listening.

tcp6       0      0           [::]:*                  LISTEN   

Screenshot of Minecraft Connection Failure: http://cld.wthms.co/IRpR/4uX2ThQ8

Process: minecra+ 26278 4.8 22.8 3517316 466356 pts/0 Sl+ 04:21 0:23 java -Xms1024M -Xmx1536M -jar minecraft_server.1.10.2.jar -o true

Any ideas? Thanks!

4 Replies

What information/status do you get when you try to connect? (ie ignore the indication the server is offline and press connect)

(the status shown in your screen shot is indicating it did not get a reply to a UDP packet with server status, sometimes even with everything working I have to refresh to see the current server status)

The main connection is via TCP and unless you changed the port uses port 25565 (the status is on the same port but UDP) so both TCP/UDP ought to be allowed in any firewall, If UDP is blocked you can still connect to the server, but it will never tell you on the servers screen the online status/number of players.

It looks like netstat is showing you're listening on IPv6 not IPv4, I didn't look at the screenshot, I'm not familiar with that domain, I'd recommending using imgur.com for screenshots. If you're actually trying to connect over IPv6 from your client and your home ISP gives you an IPv6 address as ours does then, never mind and good luck.

PS If you actually want Minecraft to bind to the IPv4 stack, you might be able to modify the line that starts Java by adding the following so the JVM knows you want IPv4:


Hi All,

Thanks so much for the replies.

That URL is for Droplr, I use it everyday at my job. It's like imgur but it's fast and does not have any ads.

You are right, nothing is listening on IPv4. Just IPv6.

I am running with the parameter you suggested.

minecra+ 16596 26.5 20.1 1983804 411272 pts/0  Sl+  17:22   0:14 java -Xmx1024M -Xms1024M -Djava.net.preferIPv4Stack=true -jar minecraft_server.1.10.2.jar nogui

But that does not seem to work. :-(

# netstat -al | grep 25565
tcp6       0      0           [::]:*                  LISTEN   

The error I am getting in the Minecraft client is Timed Out.

So the issue is that the server is not listening on IPv4 and I need to figure out how to force that. Is that about right?

On your server, try the following (assumes the Minecraft server config is set to listen on which is any Ipv4 interface):

telnet 25565

If nothing is really listening on IPv4 then telnet should complain right away with:

telnet: Unable to connect to remote host: Connection refused

If you get something, then the server is listening so I'd assume a firewall port needs to be open. You might also check from your client (home I assume) and run (assumes you have Linux at home and nmap installed):

sudo nmap -P0 

You should see something listening on port 25565 on your server.

If not, and assuming the server has both the Minecraft server listening and the firewall (like ufw) has a port open (assumes you have a firewall installed and active on the server) then check your home client machine for a block outgoing and your home router for some type of block outgoing to that port.

If you're not sure if you have a firewall running on your server, check for a log like /var/log/auth.log or secure.log or ufw.log and see if it shows that it's blocking incoming to port 25565, assuming the Minecraft server is listening on IPv4.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct