apt-get results in 'Temporary failure resolving 'mirrors.linode.com'

My apologies as I'm sure this is operator error, but when I run agt-get update I get the following reulsts:

Err:1 http://mirrors.linode.com/ubuntu xenial InRelease                  
  Temporary failure resolving 'mirrors.linode.com'
Err:2 http://security.ubuntu.com/ubuntu xenial-security InRelease        
  Temporary failure resolving 'security.ubuntu.com'
Err:3 http://mirrors.linode.com/ubuntu xenial-updates InRelease          
  Temporary failure resolving 'mirrors.linode.com'
Err:4 http://mirrors.linode.com/ubuntu xenial-backports InRelease
  Temporary failure resolving 'mirrors.linode.com'
Reading package lists... Done        
W: Failed to fetch http://mirrors.linode.com/ubuntu/dists/xenial/InRelease  Temporary failure resolving 'mirrors.linode.com'
W: Failed to fetch http://mirrors.linode.com/ubuntu/dists/xenial-updates/InRelease  Temporary failure resolving 'mirrors.linode.com'
W: Failed to fetch http://mirrors.linode.com/ubuntu/dists/xenial-backports/InRelease  Temporary failure resolving 'mirrors.linode.com'
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/InRelease  Temporary failure resolving 'security.ubuntu.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

I've updated /etc/gai.conf to have the: "precedence ::ffff:0:0/96 100" line uncommented out to prefer IPv4, but that doesn't seem to help.


4 Replies

A bit of progress based on some help from someone in the Lets Encrypt forum.

dig ocsp.int-x3.letsencrypt.org

results in:

> ; <<>> DiG 9.10.3-P4-Ubuntu <<>> ocsp.int-x3.letsencrypt.org

;; global options: +cmd

;; connection timed out; no servers could be reached

Now I'm on the hunt for my DNS problem. I probably should just rebuild the image, but I'm really curious about the cause of this issue.

So…. I rebooted for the 4th-ish time and the problem went away. As I said, I've rebooted multiple times since the issue popped up a week ago and don't' know why this reboot did it.

I don't know where or what the issue was, but I am curious about how I could have better diagnosed the issue, particularly if it was a problem external to my server.

When this happen try to do a traceroute from the server to destination host, which will give you more information.

Thanks for the suggestion.

The 'full story' is that I started getting warnings from nginx about my Lets Encrypt cert's OCSP stapling not being configured properly. This led me to test my certificate using openssl. Tests of OCSP were were failing due to DNS issues. I then tried to run traceroute to resolve the DNS issue, but traceroute was not installed, and attempts to use 'apt-get' to install traceroute failed, so I ran 'apt-get update' to set up the box to install traceroute… but then hit the error that I originally posted about and was not able to install traceroute.

I couldn't test the DNS issue because of the DNS issue. :shock: Note to self: "Install traceroute" first thing.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct