Community

Trying to run the GNU/Hurd on a linode

Avatar forum:jbranso 3 months, 1 week ago

Hello,

I'm trying to run the GNU/Hurd as my VPS. I've been told that it's possible to run the GNU/Hurd on a linode, but I'd do it anywhere that it works. I'd love to be able to do it, but I'm having a really hard time doing said thing…

This linode guide was pretty helpful: https://linode.com/docs/tools-reference … -a-linode/">https://linode.com/docs/tools-reference/custom-kernels-distros/install-a-custom-distribution-on-a-linode/

But after I copied the installation media to /dev/sdb I get this error when I try to boot: Cannot Direct Disk boot a disk with no MBR: Linode Configuration Profile problems detected.

Several people on the #hurd irc channel seemed to think that you could run the GNU/Hurd on a linode, which is helpful! But I'm just having a hard time doing it properly.

On both my install config profile and my gnu/hurd config profile, I've set the vm mode to full virtualisation. For both of the config I'm booting directly from disk. The run level I've set to default run level.

I'm still having trouble. Anyone have any ideas?

Thanks!

3 Replies

That error message is usually caused by an ISO not having been "isohybrid"-ized (which creates an MBR boot sector). After downloading the ISO in Finnix, do xxd path/to/iso | head -n 1 on it. If it's all zeros, that's the case; I believe Finnix includes isohybrid, so you can just run that on it before dd-ing it to the disk.

So I did some googling to try to see if the iso image has an MBR. It does.

parted cd-1.iso p

Model: (file)

Disk /root/cd-1.iso: 678MB

Sector size (logical/physical): 512B/512B

Partition Table: msdos

Disk Flags:

Number Start End Size Type File system Flags

1 512B 678MB 678MB primary boot

fdisk -l cd-1.iso

Disk cd-1.iso: 646.9 MiB, 678305792 bytes, 1324816 sectors

Units: sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 512 bytes

I/O size (minimum/optimal): 512 bytes / 512 bytes

Disklabel type: dos

Disk identifier: 0x00000000

Device Boot Start End Sectors Size Id Type

cd-1.iso1 * 1 1324815 1324815 646.9M cd unknown

Both of those commands verify that the first partition starts at 512B.

Also file cd-1.iso shows this:

cd-1.iso: DOS/MBR boot sector ISO 9660 CD-ROM filesystem data 'Debian sid h-i386 1' (bootable)

So I think that there does exist an MBR.

I'm wondering if I'm somehow need to specify that the qemu image can only run on 32 bit. Does Linode offer the ability to customize the qemu options?

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct