Problem with Nginx - Would it be multi_accept? only accepts 1 requisition at a time

Avatar forum:ronaldoguedess 2 months, 3 weeks ago

I have 2 clouds here in LINODE, and I have serious problems with multi-access.

I have 1 system with 2 instances, 1 clouds for the DB and another cloud for the system and interface.

It turns out that when I am going to execute a task, for example export 100 products … The whole system freezes and no one else can access my site .. OBS: the current task continues to run and my system access only comes back to everyone when it completes action. this happens on all long tasks … like importing, exporting and connecting clients.

At that time I was exporting some products, so I could see the PUT screen connected to my cloud

~~![](<URL url=)https://i.stack.imgur.com/TTD0H.jpg" />

While I'm exporting, everyone trying to access the system can not get it .. and the message below is displayed in the chrome … Waiting for available socket.

~~![](<URL url=)https://i.stack.imgur.com/QSdDe.jpg" />

I do not know what to do, I do not understand much about Ngixn, I'll show you how my Ngixn configuration file is.

user www-data;
worker_processes 2;

pid /run/nginx.pid; include /etc/nginx/modules-enabled/*.conf;

events { worker_connections 2048; use epoll; multi_accept on; }

http {

##
# Basic Settings
##

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
# server_tokens off;
# server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log off;              # /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;
fastcgi_buffering off;

##
# Gzip Settings
##

gzip on;
gzip_disable "msie6";

# gzip_vary on;
# gzip_proxied any;
# gzip_comp_level 6;
# gzip_buffers 16 8k;
# gzip_http_version 1.1;
# gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

##
# Virtual Host Configs
##

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
}

If anyone can help me, I'll be grateful! I tried to make several changes and nothing solves … I do not know what to do … everything I'm going to do I have to wait to give 1 of tomorrow not to gain access to any client.

The cloud of the DB has 4 cores, and the cloud of the system/interface has 2 cores~~~~

0 Replies

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct