Performance issue: Apache 2.0.52 & kernel 2.6

I'm using Redhat 9/kernel 2.6 & uprgaded to Apache 2.0.52 (there was a bug in the Apache that came with Redhat 9).

All of a sudden cgi were taking up 20 seconds on a machine with no load. I changed back to kernel 2.4 and things went back to normal - cgi were taking about 1 second. I also noticed that mysql went down from 28M to 10M.

Has anyone else seen anything like this?

5 Replies

Did you

mv tls tls_disabled

for the 2.6 kernel. May be related, or not.

Thats a booting issue. I have no idea if its related.

Running Redhat 9/kernel 2.6 is OK, its upgrading Apache that causes the problem.

I thought it was a network services issue of sorts.

When I dig on 2.4 I get a result.

When I dig on 2.6 I get a segfault, until I disable tls.

Maybe apache is doing some sort of DNS thing that it didn't previously and is failing. Try using dig to display the dns for a site and see what happens.

Anyway I could be way off and it could be something completely different. If you have aleady disabled tls then it's not that.

tls is a thread issue (Thread Local Storage), if you plan on using 2.6 kernel it definitely needs to be moved out of it's default position. You'll get all kinds of weird behavior until you do (most notably segfaults)

The problem turned out to be KDE on the SUSE 9.1 system I use for software development at home.

For some reason web browsing became slower & slower & finally KDE refused to start.

But KDE as root on the same machine is lightning fast. VERY weird.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct