Cant access website on mobile data?

IDk but somehow my website doesn't work on mobile on DATA,

"This site can't be reached"
The connection was reset
Try: Checking the connection
ERRCONNECTIONRESET

Works Fine on Laptop, PC, And mobile on wifi.

I think it might be ipv6, I have the AAAA Records correctly etc… i deleted the records to see if that resolve it but no luck. i added the records once again. i've been trouble shooting this for a few hours now.

i try disabling ipv6 but when i go to disable the "Auto-configure Networking" to disable it i get an error

"Access violation I'm sorry, but you've triggered our Cross-Site Request Forgery (CSRF) prevention measure."

what to do, I haven't had this issue with "Vultr" works fine out of the box.

what do you guys suggest me to try out?

thanks!

6 Replies

As far as the IPv6 issue, I’m not too sure. But here’s a link to a post that has some staff responses to the cross site request forgery issue.
https://www.linode.com/community/questions/510/i-cant-turn-on-my-machine-because-of-access-violation-of-csrf

can you access your website via mobile data?

you might be right about IPv6. I recently installed rocketchat in one of my linodes and someone couldn't connect with their phone. I realised I needed to add an extra listen [::]:443 ssl; to my nginx config for that site and things started working correctly.

No idea what server you're using but I would check and make sure you're setting up your vhost config to listen on ipv6 as well as ipv4.

I run two WordPress based websites on one server and I have no issues accessing them across mobile or home internet connections.

But you have to provide more details about what you're running, the site's URL, etc. for help.

Greetings @Johnnyb18 & friends,

We have seen this issue with customers now and again when IPv6 is not configured properly - either in DNS records, vhost configurations, or
how the Linode has IPv6 enabled.

A way you can test your domain, to ensure it works across IPv6 mobile networks, can be be done as follows.

First you'll want to check if DNS records for IPv4 & IPv6 exist:

# dig A example.com +short
# dig AAAA example.com +short

If you get an IPv6 address, double-check the headers with curl.

# curl -4 -sIL example.com
# curl -6 -sIL example.com

More information can be found here:

https://www.linode.com/community/questions/11387/help-quotthis-site-cant-be-reachedquot-from-cellular-networks

https://www.linode.com/community/questions/16993/website-not-showing-on-mobile#answer-66944

Another pointer is that you have to turn the Network Helper off to enable IPv6 on the Linode. Once that is off, we recommend going through this Community Site post which goes over the steps in configuring IPv6.

https://www.linode.com/community/questions/16929/enable-ipv6-addresses-from-pool-permanently

https://www.linode.com/docs/networking/an-overview-of-ipv6-on-linode/#default-ipv6-configuration

I would also recommend making sure your SSL certificates are correctly applied for your subdomains. You can view more information about setting up the SSL certificates on CentOS 7 here:

https://www.linode.com/docs/security/ssl/ssl-apache2-centos/#configure-apache-to-use-the-ssl-certificate

Regarding the "Cross-site forgery requests error" - we have seen this happen to customers that have multiple Linode Manager tabs open. Make sure to enable cookies as well.

Best,
Preston
Linode Support Team

i give up, nothing worked. ipv6 needs to be disabled by default and allow the users decide if they want it or not.

My configuration was the following
Centos7 64, Lightspeed server

i try port listening,A,AAA, writing and editing files…

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct