Lish is just black box??

Hi there, we just signed up to do some test development and Lish is super important for us since we work remote at client sites and cannot install software like puTTY. That said we just deployed a Debian 9 image using the latest kernel and Lish just comes up as a black box with no prompts for login or anything. Any help would be greatly appreciated.

8 Replies

Did you press any key to wake it up?

It shows that it is running/power on. Lish is just a black box without a cursor to enter anything, and Glish is just a gray/white checkboard (I understand there are extra steps for Glish), but Lish should just work right? This is Debian 9 with the latest kernel, and I have rebooted it just to try and it still isn't working.

@MichelleLurz Are you running Lish via Browser?

@LouWestin Yes I've tried Chrome, IE, Edge and Firefox same thing
We have also submitted a ticket but no answer as yet.

Ok, yeah something is strange… I logged in to test a few servers I run. It showed some boot up information, but when I pressed the enter key, it brought up the login prompt like normal.

We are at a client site and they have proxies in place, do you know if Lish uses any ports other than 443?

My partner was able to do some digging and found the following in a JS file used in Lish.

" var socket = new WebSocket("wss://" + host + ":8181/" + session + "/weblish");"

This type of connection is not supported at our client main site proxies. Does anyone know of a work around? If not we may have to seek out another VPS provider. Which is sad for us since we really like Linode.

Hope this helps anyone else with similar issues in the future.

Any chance someone can recommend a similar VPS hosting service with a 443 based web shell access?

@MichelleLurz Why can't you fix your workflow instead? Use your own devices and/or VPN so you can use SSH normally.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct