Slackware 9.0 and 'lsmod'

I'm currently running Slackware 9.0 on my linode. Today I was playing with iptables and while it worked, I ran into a different issue.

I wanted to see what kernel modules Slackware 9.0 loaded when I ran iptables:

root@starchild:/etc# lsmod

Module Size Used by Not tainted

lsmod: QM_MODULES: Function not implemented

root@starchild:/etc# ls -l /sbin/lsmod

lrwxrwxrwx 1 root root 6 May 23 2003 /sbin/lsmod -> insmod*

root@starchild:/etc# ls -l /sbin/insmod

-rwxr-xr-x 1 root bin 144116 Feb 16 2003 /sbin/insmod*

I've no idea why lsmod is linked to insmod. I also have no idea why the lsmod perms are so wide open.

No idea if I've a rootkit problem yet but will attempt to capture some data via tcpdump. I may be overly sensitve and jumping the gun but I know I didn't set that symlink and those perms.

I'm wondering if anyone else running Slackware 9.0 on their linode can confirm this (doubt it but want to be sure).



2 Replies … ight=lsmod">

Should've done a search first :?

nods Also, to address an unrelated part of your post, where you mention the permissions for lsmod - you'll find that any symlink has those permissions. The permissions actually used depend on the target, not the link.

Just thought I'd clear that up.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct