Why are all pages except my home page seeing a 404 after an all-in-one WordPress migration?

I just imported my local .wpress file to perform an all-in-one migration of my WordPress site to my Linode, and now only my homepage is working. The other pages are showing a 404 error.

1 Reply

This can definitely be a frustrating experience, especially if you've used a tool like this in the past. There could be a few possibilities for this. One such possibility could be ModSecurity or Sushoin settings according to this help page.

What I think might be more likely, however, is a possible misconfiguration in your apache.conf (or on CentOS httpd.conf) file. I would recommend making sure AllowOverride All is included in the file for your specific hosting directory. Once you've changed the configuration, make sure to restart your Apache service.

Hope this helps!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct