I ordered another IP and ...

I recently ordered an additional IP for my linode. After 380+ days of uptime, I rebooted today and when the machine came back up, I was unable to shell into my linode.

The old IP is 66.160.141.30. The new IP is 64.62.231.220. I intend to continue to use the old IP and I'd like it assigned to eth0. The new IP is irrelevant, as I will eventually want to use eth1 but without an IP.

I used lish to gain access. I'm using Slackware 9.0. The interface I normally use, eth0, wasn't up, so I ran: /etc/rc.d/rc.inet1. eth0 came up but it was using the new IP instead of the old one. I tried to bring up the old one and assign it the device eth1 but apparently the system doesn't like it, as its only noticing eth0, not eth1:

[email protected]:/etc/rc.d# ifconfig eth1 66.160.141.30

SIOCSIFADDR: No such device

eth1: unknown interface: No such device

'ifconfig eth0' shows:

eth0 Link encap:Ethernet HWaddr FE:FD:40:3E:E7:DC

inet addr:64.62.231.220 Bcast:64.62.231.255 Mask:255.255.255.0

inet6 addr: fe80::fcfd:40ff:fe3e:e7dc/64 Scope:Link

UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1

RX packets:252 errors:0 dropped:0 overruns:0 frame:0

TX packets:61 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:31714 (30.9 Kb) TX bytes:8650 (8.4 Kb)

Interrupt:5

In the meantime I'll continue to figure out what's going on and how to revert back to my old IP. That should be easy. The hard part may be getting eth1 up and functional alongside eth0 but without an IP assigned to it.

EDIT AGAIN:

I've currently got both interfaces up and running with both IPs, so things are stable for now. I'm still trying to figure out how to bring up an interface that has no IP assigned to it, though.

1 Reply

I guess I got things working like I wanted:

[email protected]:~# ifconfig eth0:2 up

SIOCSIFFLAGS: Cannot assign requested address

[email protected]:~# ifconfig eth0:2

eth0:2 Link encap:Ethernet HWaddr FE:FD:40:3E:E7:DC

UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1

Interrupt:5

I did 'tcpdump -i eth0:2' and was able to get a dump, so I guess things are working as they should.

EDIT:

I don't think its possible to set up snort on this interface and have the interface truly isolated on a linode. When I do a tcpdump, I see traffic from both interfaces. Reading Linode's networking setup howto, it even explains that all traffic must go through eth0. That brings up the question: "if I've several apps (maybe several busy web servers) assigned to several IPs and they are all going through eth0, will there be an issue with bandwidth? Specifically, will there be what amounts to network congestion local to that machine?

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct