Account Is Currently Not Available (Putty)

Linode Staff


I am able to reach my server via SSH but the connection closes as soon as I put the password in.

This only happens when I log in with one of two users on the server and I can connect fine when using the other.

Putty log says:

Using username "XXXXXXX"
Keyboard-interactive authentication prompts from server:
| Password: XXXXXXXX
End of keyboard-interactive prompts from server
Last login: Wed Apr 15 11:23:08 2020

This account is currently not available.

3 Replies

I did some quick researching on This account is currently not available. in relationship to SSH log-ins it looks like your problem may be a result of not having a valid shell program assigned to communicate with Linux.

This article from goes into step by step detail for setting a shell for the user in question and could be a great starting point.

You can resolve this error by setting up a shell for the desired user. You can do this through the "chsh" command or editing the /etc/passwd file. If not, try toedit the /etc/passwd file manually and set the desired shell. Now you should be able to log in to your user account via SSH or "us".

Editing adduser.conf(5) and changing DSHELL to some value will make that value the default shell for every user that's created with adduser(8)…unless overridden with options. Here's a snippet of my adduser.conf(5) file:

# /etc/adduser.conf: `adduser' configuration.
# See adduser(8) and adduser.conf(5) for full documentation.

# The DSHELL variable specifies the default login shell on your
# system.

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct