My subdomain works fine, but my domain is showing DNS_PROBE_FINISHED_NXDOMAIN


I was able to set up a linode server and point a domain from where I got it to the server. I created the domain zone on linode and It was working at first for a few hours, then it suddenly stopped and started showing DNS_PROBE_FINISHED_NXDOMAIN on chrome.

I added an A record for the subdomain and it works fine. But my domain still shows DNS_PROBE_FINISHED_NXDOMAIN.

The domain is and the subdomain is

I ran this command on the domain

dig +trace | grep

and it shows this 3600 IN NS 3600 IN NS 3600 IN NS 3600 IN NS 14400 IN SOA 2020051507 14400 14400 1209600 14400

Please what am I doing wrong?

3 Replies

It looks like you may not have an A record for your base domain. I didn't receive a response when running dig +short, while I do receive a response for an A record on your subdomain:

dig +short

Adding an A record pointing to your Linode for with a blank hostname, along with a hostname of www if desired, should clear up the DNS error you're seeing.

This worked for me. I created A record for both and it shows now. Thank you for your help

@bashir05 - If you recently made a change to your DNS records, it can take some time for the records to propagate. Full propagation can take up to 24-48 hours, but you should start to see your changes within a few hours.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct