Jabberd2 Works for users inside the server, but not S2S...

I've got Jabberd2 working fine on my server, and alice@autodmclabs.com can contact bob@autodmclabs.com and vice-versa… but if bob@autodmclabs.com tries to contact autodmc@jabber.org I get a 404 error!

I'm not quite sure what I've done wrong, and I don't know where to edit to make this work.

Also… does anyone know how to install MUC onto Jabberd2 on Ubuntu?

I will be doing more research when I get home later tonight, but I wanted to try to cheat and pick some brains…

2 Replies

sounds like you haven't got port 5269 open?

if you're still using firehol, you need to make sure you have "server jabberd accept", not just "server jabber accept"… I think I'm right in saying you have "client all accept", but you'll at least need "client jabberd accept"

try it with your firewall down if this doesn't work, I don't use jabberd2 any more, you may well need to specifically enable s2s communication…

as far as I know, you just need to apt-get install jabber-muc then adjust the config for your server name, this sort of stuff is all quite well documented over at jabber.org.

I've got "server jabberd accept" and "client all accept," so perhaps there's something in the config files…

Unfortnatly, Jabber-MUC for Ubuntu wants Jabber1.4, not Jabber2 to work. I've found a workaround, but it requires compiling the "Jabber Runtime Wrapper Thing" and MUC, then installing them… but I haven't gotten anything to compile on my Linode yet, so more work there…

…I was just lamely hoping there was an easier way to do that…


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct