How to use NixOS on ZFS on a Linode?


I am attempting to install NixOS on ZFS by following a combination of this plus this; however, I'm running into trouble when booting, where the Linode states that the grub variable "prefix" isn't set. I tried using the GRUB 2 kernel, as well as a Direct Disk method, but neither seem to work.

Any help on the matter would be greatly appreciated!

2 Replies

We've seen this error occur on a few distributions, including Fedora and CentOS. This Community Questions post might offer some troubleshooting advice and insight. NixOS also briefly mentions the need to set boot.loader.grub.device in their documentation. I did also want to note that we currently don't support ZFS by default; you'd need to use a raw disk in order to use ZFS, as mentioned in this Community Questions post. If you're using an ext4 disk as suggested in our NixOS guide, this may be causing the issue you're seeing when booting.

I'm using a raw disk formatted to ZFS for the NixOS boot configuration, and I've set the grub device as a seperate disk formatted to vfat using mkfs.vfat, which might be causing the problem. I tried using parted and setting the esp flag, but it apparently didn't work either. I could post my configuration files, if those would help? Although to do so, I'd need to get them off the disk, which I don't yet know how…


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct