Why am I being disconnected from my Linode after a few minutes of inactivity?

Linode Staff

Anytime I leave my Linode inactive for a few minutes, I am disconnected from my SSH session. How can I increase this interval so I don't need to log in so frequently?

1 Reply

Linode Staff

We typically find that connectivity timeouts are a result of a setting in place for the SSH client as opposed to the Linode itself, but there are a couple of things you can do to narrow down the cause and fix this issue. For your Linode, adding a line to /etc/ssh/sshd_config that states ClientAliveInterval 60 should prevent you from seeing a timeout error. The same can be done on your local computer. Both options are described in this article.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct