Domain does not connect to linode server

Hi, I was wondering if anyone could help me out. I bought a domain off of godaddy for and when I first got it I set up the A record and it worked fine but I moved some stuff out of folders that I had on my server so that the homepage would just pull up when I type in and nothing else. That was the goal and it works when I just type the IP address of my server, but when I type it leads to a blank screen. Also, before when I would do ifconfig it would pull up an IP address that was different from my server's IP, but I messed around with stuff and now when I do ifconfig it just says " error fetching interface information: Device not found". Is there a way to fix this? I'm not even really sure what I did, I think I was messing with clearing out the dns cache because I thought maybe that was why it wasn't working in the first place but it seems I just made things worse.

3 Replies

Hi there -

Thanks for reaching out with this. I started off by running a dig on your domain:

$ dig +short

It did not return an IP address, which is what it should do if the DNS is configured properly. The first thing I would do is check that. You can use our DNS set-up checklist to help out.

The reason I bring up DNS is because when I try to navigate to your website, I get the following:

This site can’t be reached’s server IP address could not be found.


Checking the connection
Checking the proxy, firewall, and DNS configuration

You did mention that this worked before, which leads me to believe that the DNS was configured correctly at one time. Did you change anything in your DNS configuration in the Cloud Manager?

You also mention the error that you received when running ifconfig. Since we can't see into your Linode's internals, it's hard to say what might be causing that although it could be related. To help as best I can, I want to refer you to our static networking guide which might be useful to you:

Static Networking

I'm also going to add some tags to this post to give it more visibility to other members of the Linode Community who might be able to offer more help than what I've given.

Hey there,

I just wanted to add, I took a look at this issue as well and I believe I found two specific DNS related issues happening here.

First, your domain has conflicting NS records:

 dig ns +short

In general, you should have NS records for either Linode or GoDaddy, but this shows both ( and are GoDaddy Nameservers). I would recommend removing those nameservers from the list at your registrar so only the Linode nameservers appear. This will prevent conflicts between the Linode nameservers and the GoDaddy nameservers.

The second issue I saw was that there was no A record for your domain on the Linode nameservers:

dig a

; <<>> DiG 9.10.6 <<>> a
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34096
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
;; WARNING: recursion requested but not available

; EDNS: version: 0, flags:; udp: 1232
;            IN  A

;; AUTHORITY SECTION:        86400   IN  SOA aleksandra\ 2021000010 14400 14400 1209600 86400

;; Query time: 101 msec
;; WHEN: Fri Aug 14 17:07:39 EDT 2020
;; MSG SIZE  rcvd: 119

There is no IP answer section in that response, which indicates the A record is not there. When I run dig a +short the response is blank. You mentioned you had added an A record, so on a hunch I checked for a common misconfiguration:

dig a +short

For privacy's sake I have hidden the server's IP address. This issue occurs when you add the A record to DNS manager and enter the domain in the hostname field. If you wish to add an A record to the DNS manager for the base domain, you should leave the hostname field blank. Enter your Linode's IP address in the IP address field, then submit it. After a few minutes the command dig a +short should return your Linode's IP address.

I hope this helps!

Thank you so much! I fixed the name servers and A record and it is working now!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct