Default document on static site in object storage with custom url

I have a static site in an object storage bucket. When I access the site from https://my.url.com.website-us-east-1.linodeobjects.com/ the default document in the command s3cmd ws-create --ws-index=index.html --ws-error=404.html s3://my.url.com works properly even in subdirectories.

When I access the site at my.url.com. The SSL cert works properly everything is fine, but the default documents don't work so I get key not found errors if I go to my.url.com/about but not my.url.com/about/index.html.

What did I do wrong?

2 Replies

@screenwavemedia I can't be entirely certain what is causing your issues, but it may help to check that your website configuration includes a 404 html page using the below command:

 s3cmd ws-info s3://my.url.com

The below link may also provide some additional troubleshooting steps that are particular to your situation.

This is actually a bug in Linode's implementation. It works fine when you use their bucket website hostnames, but not when you use your own host name. With your own hostname default document is totally broken. This prevents using linode's object storage for static sites with custom domains where you need default document functionality. I tried the same thing on Amazon S3 and it worked fine.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct