Moronic Dapper package

I just upgraded Ubuntu Breezy->Dapper via apt.

Mysql immediately went borked so I re-compiled my own, which again immediately went borked.

So I do 'make clean' and figure, go the easy route, install the package.

I go to install mysql-server-4.1 off apt. And what do I get?? This:

> ryantate ~ [514] apt-get install mysql-server-4.1

Reading package lists… Done

Building dependency tree… Done

The following extra packages will be installed:

libdbd-mysql-perl libdbi-perl libmysqlclient14 libmysqlclient15off

libnet-daemon-perl libplrpc-perl mailx mysql-client-4.1 mysql-common postfix

Suggested packages:

dbishell libcompress-zlib-perl procmail postfix-mysql postfix-pgsql

postfix-ldap postfix-pcre sasl2-bin

Recommended packages:


The following NEW packages will be installed:

libdbd-mysql-perl libdbi-perl libmysqlclient14 libmysqlclient15off

libnet-daemon-perl libplrpc-perl mailx mysql-client-4.1 mysql-common

mysql-server-4.1 postfix

Yes, that's right – if I want the database server, it wants to install an email server (postfix) as precondition!

This has to be the STUPIDEST thing I have EVER seen. :roll:

God I wish I had never upgraded. What a waste of a Saturday.

Bitterly, R

7 Replies

And the reason mysql started borking on startup all of a sudden?

When I first setup my Linode, I somehow got it into my head that it was OK (and necessary) to have multiple lines in the hostname file, for multiple valid hostnames.

The old Ubuntu just used the first line. The new Ubuntu was concatenating all the lines together, newlines and all. Mysql was trying to read or create /usr/local/var/$HOSTNAME on startup and the newlines were screwing everything up.

I had fixed the hostname already when I was working on these problems, since it had been screwing up my command line. But I had not reboot or restarted my shell since then. Once I did so, mysql worked fine.

mysql-server-4.1 /does/ require some sort of MTA (indirectly) - it likes to mail you warnings when maintenance jobs detect problems - corrupt tables etc.

I'd suggest you let it install postfix and configure it for local delivery only (one of the options you'll be presented with). This way you're not really running an "email server", you're just allowing local users to mail each other - which is how the mysqlcheck cron job will report any problems to you.

if you want to monitor your server at all, don't forget to check your mail on it once in a while :)

Interesting TehDan, I did not know that. cron works similarly, I believe. I guess my issue is I don't want to give up the memory needed for postfix. But at least now I understand the reasonig/

I'm not that familiar with the Debian packaging methodology, but does it need Postfix, or just any MTA?

I would imagine that there may be a more lightweight alternative.

any MTA will do. Somthing like nullmailer will save you a little bit of ram, by relaying all mail via an external SMTP server… if you don't have one / want to set one up then postfix configured for local devliery only will use very little RAM.

Oooh, nullmailer sounds perfect, thanks for the tip. It fixes my main issue with configuring postfix as local-only: its no better than a log because I have to be ssh-ed in to read the messages. Nullmailer would send things to my main email account (not on Linode).

PS on a purely philosophical level, I still think all this stuff should just use syslog. IIRC, syslog can be set up to send email at certain loglevels if that's what one wants. I still don't think my rdbms should be trying to send mail (though it perhaps presents the server side corollary to Zawinski's Law of Software Envelopment; instead of evolving until it reads mail, server software evolves until it sends mail).


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct