✓ Solved

How to make ingress work without appending nodeport to the hostname?

I'm trying a simple microservices app on a cloud Kubernetes cluster. This is a part of the Ingress yaml:

  - host: somehostname.xyz

I've added the DNS A record as *.somehostname.xyz.

The problem:
When I use this URL, I'm able to access the auth service: http://somehostname.xyz:31840. However, if I use http://somehostname.xyz, I get a "This site can’t be reached somehostname.xyz refused to connect." error.

All the services, deployments, nginx ingress controller etc. are running fine. What causes this kind of a problem and how to solve it?

1 Reply

✓ Best Answer

Solved it. The solution was to search for the ingress service that was running, and to use the external IP of that service for creating the DNS A record. Earlier I was using the external IP of the worker node.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct