apt-get apt install not working when Linode Firewall is enabled

Firewall is set to default block inc and out, but I have all the default rules allowed for both IPv4 and 6 (HTTP, HTTPS, DNS, SSH) on both incoming and outgoing.

If I disable the firewall, my Linode can connect successfully using apt-get and apt install

Any ideas?

3 Replies

It is like DNS breaks. Cant ping via domain names, ping via IP works fine.

I believe you need to unblock HTTP (80) as well.

-- sw

Have you enabled DNS outbound for both UDP and TCP protocols?

DNS initially uses UDP and “upgrades” to TCP for bigger result sets (such as DNSSEC.)

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct