Yum Dependency Issue

Linode Staff

I am not able to do yum update. I am getting dependencies issues. I also tried to install php 8 and getting the same error. I tried everything available on net but getting same error. Can you please help me with this?

yum update error

--> Finished Dependency Resolution
Error: Package: 1:nginx-mod-http-image-filter-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: 1:nginx-mod-http-perl-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: 1:nginx-mod-stream-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: php-pecl-recode-1.0.0~DEV.20190723-3.el7.remi.7.4.x86_64 (@remi-php74)
Requires: php(api) = 20190902-64
Removing: php-common-7.4.26-1.el7.remi.x86_64 (@remi-php74)
php(api) = 20190902-64
Updated By: php-common-8.0.13-1.el7.remi.x86_64 (remi-php80)
php(api) = 20200930-64
Available: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
php(api) = 20100412-64
Available: php-common-8.0.12-1.el7.remi.x86_64 (remi-php80)
php(api) = 20200930-64
Error: Package: php-pecl-recode-1.0.0~DEV.20190723-3.el7.remi.7.4.x86_64 (@remi-php74)
Requires: php(zend-abi) = 20190902-64
Removing: php-common-7.4.26-1.el7.remi.x86_64 (@remi-php74)
php(zend-abi) = 20190902-64
Updated By: php-common-8.0.13-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64
Available: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
php(zend-abi) = 20100525-64
Available: php-common-8.0.12-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64
Error: Package: 1:nginx-mod-http-xslt-filter-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: 1:nginx-mod-mail-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-headers-3.10.0-1160.45.1.el7.x86_64 is a duplicate with kernel-headers-3.10.0-1062.18.1.el7.x86_64
kernel-tools-libs-3.10.0-1160.45.1.el7.x86_64 is a duplicate with kernel-tools-libs-3.10.0-1062.18.1.el7.x86_64

Yum upgrade error

--> Finished Dependency Resolution
Error: Package: 1:nginx-mod-http-image-filter-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: 1:nginx-mod-http-perl-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: 1:nginx-mod-stream-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: php-pecl-recode-1.0.0~DEV.20190723-3.el7.remi.7.4.x86_64 (@remi-php74)
Requires: php(api) = 20190902-64
Removing: php-common-7.4.26-1.el7.remi.x86_64 (@remi-php74)
php(api) = 20190902-64
Updated By: php-common-8.0.13-1.el7.remi.x86_64 (remi-php80)
php(api) = 20200930-64
Available: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
php(api) = 20100412-64
Available: php-common-8.0.12-1.el7.remi.x86_64 (remi-php80)
php(api) = 20200930-64
Error: Package: php-pecl-recode-1.0.0~DEV.20190723-3.el7.remi.7.4.x86_64 (@remi-php74)
Requires: php(zend-abi) = 20190902-64
Removing: php-common-7.4.26-1.el7.remi.x86_64 (@remi-php74)
php(zend-abi) = 20190902-64
Updated By: php-common-8.0.13-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64
Available: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
php(zend-abi) = 20100525-64
Available: php-common-8.0.12-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64
Error: Package: 1:nginx-mod-http-xslt-filter-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
Error: Package: 1:nginx-mod-mail-1.20.1-9.el7.x86_64 (installed)
Requires: nginx(abi) = 1.20.1
Removing: 1:nginx-1.20.1-9.el7.x86_64 (installed)
nginx(abi) = 1.20.1
Updated By: 1:nginx-1.20.2-1.el7.ngx.x86_64 (nginx)
Not found
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-headers-3.10.0-1160.45.1.el7.x86_64 is a duplicate with kernel-headers-3.10.0-1062.18.1.el7.x86_64
kernel-tools-libs-3.10.0-1160.45.1.el7.x86_64 is a duplicate with kernel-tools-libs-3.10.0-1062.18.1.el7.x86_64

Regarding php.

I tried that but same error as yum update. - yum install -y --enablerepo=remi-php80 php php-cli

---> Package php-xmlrpc.x86_64 0:7.4.26-1.el7.remi will be obsoleted
--> Finished Dependency Resolution
Error: Package: php-pecl-recode-1.0.0~DEV.20190723-3.el7.remi.7.4.x86_64 (@remi-php74)
Requires: php(zend-abi) = 20190902-64
Removing: php-common-7.4.26-1.el7.remi.x86_64 (@remi-php74)
php(zend-abi) = 20190902-64
Updated By: php-common-8.0.13-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64
Available: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
php(zend-abi) = 20100525-64
Available: php-common-8.0.12-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64
Error: Package: php-pecl-recode-1.0.0~DEV.20190723-3.el7.remi.7.4.x86_64 (@remi-php74)
Requires: php(api) = 20190902-64
Removing: php-common-7.4.26-1.el7.remi.x86_64 (@remi-php74)
php(api) = 20190902-64
Updated By: php-common-8.0.13-1.el7.remi.x86_64 (remi-php80)
php(api) = 20200930-64
Available: php-common-5.4.16-48.el7.x86_64 (base)
php(api) = 20100412-64
Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
php(api) = 20100412-64
Available: php-common-8.0.12-1.el7.remi.x86_64 (remi-php80)
php(api) = 20200930-64
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-headers-3.10.0-1160.45.1.el7.x86_64 is a duplicate with kernel-headers-3.10.0-1062.18.1.el7.x86_64
kernel-tools-libs-3.10.0-1160.45.1.el7.x86_64 is a duplicate with kernel-tools-libs-3.10.0-1062.18.1.el7.x86_64

1 Reply

Hey there,

I spun up a CentOS 7 Linode and tested some of this. The first thing I did was add the EPEL and Remi repos by following this guide:

[[email protected] ~]# yum install -y https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

[[email protected] ~]# yum install -y https://rpms.remirepo.net/enterprise/remi-release-7.rpm

Both of these ran successfully on my Linode. I can see that the Remi repos have been enabled by looking under /etc/yum.repos.d/:

[[email protected] yum.repos.d]# ls
CentOS-Base.repo       CentOS-Media.repo          epel.repo          remi-glpi93.repo   remi-php70.repo  remi-php74.repo  remi-safe.repo
CentOS-CR.repo         CentOS-Sources.repo        epel-testing.repo  remi-glpi94.repo   remi-php71.repo  remi-php80.repo
CentOS-Debuginfo.repo  CentOS-Vault.repo          remi-glpi91.repo   remi-modular.repo  remi-php72.repo  remi-php81.repo
CentOS-fasttrack.repo  CentOS-x86_64-kernel.repo  remi-glpi92.repo   remi-php54.repo    remi-php73.repo  remi.repo

Once that was done, I was able to install PHP 8.0 by running this command:

[[email protected] ~]# yum install -y --enablerepo=remi-php80 php php-cli

I’m able to verify my currently installed PHP version like so:

[[email protected] ~]# php -v
PHP 8.0.13 (cli) (built: Nov 16 2021 18:07:21) ( NTS gcc x86_64 )

So it’s definitely possible to get PHP 8.0 working on CentOS 7. It seems like there might be something deeper going on with your system. This Stack Overflow post (with an answer from the maintainer of Remi’s Repo) outlines a similar problem:

https://stackoverflow.com/a/34470482

It looks like the package php-pecl-recode might be causing problems:

Error: Package: php-pecl-recode-1.0.0~DEV.20190723-3.el7.remi.7.4.x86_64 (@remi-php74)
Requires: php(zend-abi) = 20190902-64
Removing: php-common-7.4.26-1.el7.remi.x86_64 (@remi-php74)
php(zend-abi) = 20190902-64
Updated By: php-common-8.0.13-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64
Available: php-common-5.4.16-48.el7.x86_64 (base)
php(zend-abi) = 20100525-64
Available: php-common-5.4.45-18.el7.remi.x86_64 (remi)
php(zend-abi) = 20100525-64
Available: php-common-8.0.12-1.el7.remi.x86_64 (remi-php80)
php(zend-abi) = 20200930-64

You might have luck removing that package:

yum remove php-pecl-recode

If that works, try doing another update with yum update. If that works, you might be able to try installing PHP 8.0 from Remi’s Repo again.

If you run into further problems, feel free to respond to this post. Someone from the Linode Community might be able to provide you with guidance.

Two more things: if you haven’t seen it already, there’s a great Remi’s Repo configuration wizard that might be helpful:

https://rpms.remirepo.net/wizard/

You can also reach out to the Remi’s Repo forums for help:

https://forum.remirepo.net/viewforum.php?id=5

Hope this helps. Good luck!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct