Can't search for Wordpress Themes or Plugins

Warning: An unexpected error occurred. Something may be wrong with or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to Please contact your server administrator.) in […]/wp-includes/update.php on line 413.

From my own research it looks like this is usually caused by there not being a php-curl (included in php-common on rhel distros) or a firewall issue.

Neither seem to be my issue.

$ php

Return no errors or warnings

$ openssl s_client -connect

Shows that I can connect just fine.

The user "nginx" is the owner of the directories and has write permissions so I'm kind of at a loss.

Other notes:

I've added the following to my wp-php.ini to try to enable debugging:

define( 'WP_DEBUG', true );

define( 'WP_DEBUG_LOG', '/tmp/debug.log' );

define( 'WP_DEBUG_DISPLAY', true );

@ini_set( 'display_errors', 0 );

But I'm not getting a debug.log file

3 Replies

So… install php-curl… easy peasy.

But I'm not getting a debug.log file

Did you restart your web server and/or php-fpm?

-- sw

So… install php-curl… easy peasy.

I said in the OP that it wasn't my issue. I have php-common installed already which provides php-curl.

Did you restart your web server and/or php-fpm?


sudo systemctl restart php-fpm && sudo systemctl restart nginx

Here's the curl information from phpinfo


cURL support => enabled
cURL Information => 7.61.1

Then I would look at WP. In this world, you are on your own.

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct