✓ Solved

Unable to host website with nginx

I am trying to serve a website (proxied with cloudflare) with nginx. every time i try to access the website via the ip i get connection timed out, and every time i try it through cloudflare i get Error 523 (Origin Server Unreachable). I have tried everything i can think of to fix it but nothing works. I do not have any firewall installed on the server (it is a almost-fresh install of CentOS stream 9), and only country blocking on cloudflare.

Server OS: CentOS Stream 9
Client OS: Windows 10
Client Browser: Firefox

2 Replies

✓ Best Answer

CentOS Stream 9 ships with firewalld enabled by default, you will need to add rules to allow port 80 and 443.

firewall-cmd --permanent --zone=public --add-port=80/tcp
firewall-cmd --permanent --zone=public --add-port=443/tcp
firewall-cmd --reload

Thank you so much for the help and very fast reply @ckaczynski!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct